注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

手札' 飞翔的石头

兔年 新兔样

 
 
 

日志

 
 

基于SLIP/PPP实现广域网互连 (转)  

2011-04-25 20:35:53|  分类: 积累点滴 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

原文http://www.yesky.com/SoftChannel/72355561689055232/20000615/80865.shtml

本文主要介绍企业计算机网络系统中较普遍采用的几种基于PPP/SLIP的广域网互连方式,并结合实例说明路由器、modem等互连设备的配置。

本地和远程局域网通过路由器拨号互连

基于SLIP/PPP实现广域网互连 (转) - 水底的石头 - 手札    飞翔的石头

  

 

图1 局域网通过路由器拨号连接

  如图1,这是一种最典型的DDR(Dialer-on-Demand Routing)即按需拨号连接方式。
  图中路由器Router1的E0地址为:172.22.32.17 ,
  异步口A6地址为:172.22.32.33,
  Router2的E0地址为:172.22.37.1,
  异步口A6地址为:172.22.32.34。
  子网掩码为:255.255.255.248。
  要实现该方式的网络互连,必须正确配置路由器Router1、Router2和调制解调器。

  1.路由器(以Router1为例)的配置

  (1)全程参数(Global Parameters)的配置

  全程参数包括路由器名(hostname)、口令(enable secret)、以太网地址(ethernet address)等。具体配置较简单,可参考有关路由器说明书。

  (2)异步口(Async)的配置

  路由器异步口的配置,包括异步接口(Async)和对应异步线(Line)的配置两部分。
  Line的配置用于Async口的以下选项:
  ●物理层选项,包括流控制,速率等;
  ●EXEC安全保护,即登录限制方式;
  ●异步协议的自动选择(Autoselect),自动检测、启动PPP或SLIP协议。
  ASYNC的配置包括下列特性:
  ●支持的网络协议,如IP协议;
  ●缺省的协议封装(PPP/SLIP等);
  ●客户IP地址(缺省或动态);
  ●PPP认证(SLIP无认证机制)等。
  具体的配置参数如下:
  interface Async6
  ip address 172.22.32.33 255.255.
  255.248 ;A6口IP地址
  encaps ppp ;封装PPP
  async default routing ;异步缺省路由
  async mode dedicated ;异步专用模式
  dialer in-band ;启动拨号方式
   ler string XXXX ;对方电话号码
  dialer-group 1 ;建立拨号组
  pulse-time 1
  line 6
  modem InOut ;允许拨入/拨出
  script dialer call ;拨号脚本
  transport input all ;允许TELNET连接
  stopbits 1 ;
  flowcontrol hardware ;
  speed 38400;物理特性,停止位为1,硬件;流控, 最大传输速率38400
  (3)IP 路由协议包括:
  ●路由信息协议(RIP);
  ●静态路由(固定的路由表项)。
  配置如下:
  router rip
   redistribute static ;广播静态路由
   passive-interface Async6
  ;A6为消极路由
   network 172.22.0.0
  ip default-gateway 172.22.32.17;缺省网关
  ip classless
  ip route 172.22.0.0 255.255.0.0 172.22.32.16 ;
  ip route 172.22.0.0 255.255.0.0 172.22.32.32 ;
  ip route 172.22.37.216 255.255.255.248 Async6 ;静态路由表

  2?调制解调器的配置

  要使互连的网络能够正常通信,必须正确设置调制解调器。不同的调制解调器参数的设置有所不同,但必须与路由器异步口的配置一致。其中,下面几个参数是必需的:
  ●锁定RS-232口的速率;
  ●采用硬件数据流控制(即用RTS/CTS信号控制数据流);
  ●采用DCD指示载波的变化;
  ●DTR信号由“ON”到“OFF”时,modem重置所有的设置状态等等,尽量不采用纠错和压缩功能。
  较常用的几种调制解调器的初始化字符串如下:
  Hayes: AT&FS0=1&C1&D3&K3&Q9&W
  Motorola: AT&FS0=1&C1&D3\Q3\J0\N3%C1&W
  Multitech: AT&FS0=1&C1&D3&E4$BA0$SBxxxxx&E0&E14&W
  这里,xxxxx 与路由器Line配置的速度匹配。

二、通过网络服务器与本地路由器拨号互连

基于SLIP/PPP实现广域网互连 (转) - 水底的石头 - 手札    飞翔的石头

  

 

图2 远程服务器与本地路由器的拨号连接
  如图2,这种连接方式与前一种连接方式相比,远程局域网不通过路由器而是直接由服务器异步口(COM1)通过拨号连入本地局域网。尽管没有图1连接方式可扩展性强,但应用非常灵活,特别对于连网计算机较少、业务量和传输量不大的远程局域网的连入非常适用,而且在实践中这种连接方式比较普遍。
  图2的连接方式,路由器、modem的配置与图1中的配置基本一样,只是在Async口的配置中,加入服务器COM1口地址:
  peer default ip address 172.22.32.26
  在服务器中配置拨号网络(以OS/2拨号网络为例):
  (1)注册信息中,通信协议选择SLIP,电话号码填写与路由器端相连的电话号码;
  (2)连接信息中,
  你的IP:172.22.32.26
  目的IP:172.22.32.25
  子网掩码:255.255.255.248
  (3)调制解调器,按连接的modem配置有关参数。
  配置完成后,即可通过拨号连入本地局域网,实现信息的传递和交换。

三、DDN专线连接方式

基于SLIP/PPP实现广域网互连 (转) - 水底的石头 - 手札    飞翔的石头

  

图3 DDN专线连接方式

  
  如图3,以上两种拨号连接方式,都可以通过专线方式实现,与拨号连接相比,专线连接可靠性高、传输稳定,但需独占话路,特别是租用DDN,费用较高。
  专线连接方式中路由器的配置与上述方式相似,只是去掉有关拨号的参数。modem设置为专线方式,其中一方设为应答方式(Answer),另一方设为呼叫方式(Originate),其他参数相同。
本文结合作者在企业计算机应用系统中的实践,介绍了目前企业计算机联网中常用的几种基于PPP/SLIP的广域网互连方式及其具体实现。这些实例都在实际应用中调试通过并投入使用。

  评论这张
 
阅读(111)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017